MacInTouch Reader Reports

Hard Drives: Western Digital

Jan. 2, 2009
Jan. 6, 2009
Jan. 7, 2009
Jan. 8, 2009
Jan. 9, 2009
Jan. 30, 2009
Jan. 31, 2009
Feb. 2, 2009
Feb. 4, 2009
Feb. 5, 2009
Feb. 7, 2009
Feb. 9, 2009
Feb. 10, 2009
Mar. 17, 2009
Mar. 18, 2009
Mar. 19, 2009
Mar. 20, 2009
May. 14, 2009
Aug. 20, 2009
Aug. 21, 2009
Aug. 29, 2009
Aug. 31, 2009
Sep. 5, 2009
Sep. 8, 2009
Sep. 9, 2009
Dec. 7, 2009
Dec. 8, 2009
Dec. 9, 2009
Dec. 11, 2009
Dec. 14, 2009
Dec. 23, 2009
Dec. 24, 2009
Dec. 28, 2009
Dec. 29, 2009
Jan. 12, 2010
Jan. 13, 2010
May. 17, 2010
May. 18, 2010

Newer entries...
Jan. 2, 2009

item.84412

Joe F

As follow-up to Kwan's experience with a WD drive it's worth repeating: NEVER install the software that comes with a WD My Book hard drive. That is what causes the vast majority of the problems with these drives, all for the sake of the supposedly "smart" power button and the silly capacity gauge (does your free space really change so frequenctly and dramatically that you need a gauge on the outside of your hard drive?).

I never installed the software that came with my My Book Studio and have never had a problem after nearly a year of daily use. The capacity gauge acts as a disk activity light without the software. Now if they would just make the light smaller or at least dimmer it would be nice. It's very bright, and the Cylon-like motion is very distracting when watching movies in a dark room!

item.84431

MacInTouch Reader

My understanding is that (some?) Western Digital drives supply the same sort of motion-sensed head parking mechanism as Apple's Sudden Motion Sensor, and the two conflict, causing kernel panics.

Apple supports disabling the Sudden Motion Sensor mechanism:

http://support.apple.com/kb/HT1934

That may be preferable, if disabling the WD mechanism removes other features with it.

Jan. 6, 2009

item.84730

Scott Bartlett

Further to Fred Stratton's comments on the WD "Elements" entry-level drive, I too have one of these. I picked it up a couple of days after Christmas whilst browsing in a local PC superstore (PC World). It cost me the grand sum of just ?68 (UK Pounds, including VAT at the new current UK rate of 15%). Even with the state of Sterling compared to the Dollar this is pretty good for an external terabyte drive. I make that 6.8 pence per unformatted gigabyte, or about 7.3 pence formatted.

It's only USB2 but I'm only using it for disk clone and Time Machine backups as well as extra mass storage for non-essential stuff so performance isn't critical for me and, so far at least, it does what it says on the tin and is nice and quiet to boot.

I was half expecting it to be rather rubbish, but I've been pleasantly surprised. So far at least...

Jan. 7, 2009

item.84809

Randall Voth

A small point about Western Digital drives: I have a 320 Passport external that has been excellent for a year: silent and only uses one USB port for bus power on a Mac mini.

Today, I received 2 WD Green Power 1 TB drives for an NAS. They don't spin as fast as other drives so they use less power. I also have a Samsung Spinpoint 1 TB and two Seagate 1 TB drives. The Seagates are the hottest and buzziest. The Samsung also vibrates, but not so much as the Seagates. The Green Power drives are silent and do not vibrate at all.

With the Samsung drive, I had to place the NAS on a piece of foam to keep it quiet, but the WD drives need no such measure. The WD drives are probably a bit slower than the others, but my NAS is an awful lot slower than any SATA drive out there, as are most NAS available under $1000, so it makes no difference in my application.

I think the Green Power drives are an excellent choice for large amounts of network storage, especially if they are to be located in a quiet environment.

Jan. 8, 2009

item.84834

Bill Schwartz

Regarding Randall Voth's recommendation of Western Digital Green Power drives: I concur, having recently purchased two 500GB models for use as rotating Time Machine backup disks internally in my Mac Pro. They are essentially silent and very fast (I also keep a nightly clone of my boot drive on a partition of these drives, so I can judge their speed when I boot from them).

I also purchased a high performance WD 640GB "Blue" model to use as a boot drive. It is also close to silent and amazingly fast"as expected since it's one of the fastest SATA drives currently available according to reviews. Based on what I know now, and my needs, I can't imagine purchasing anything else. The prices are also low. In comparison, the Seagate drive my early '08 Mac Pro shipped with is plodding and ear splitting. A night and day difference.

I considered the "Black" version for a boot drive. Reportedly, it's a little faster than the "Blue," but significantly noisier, not a a tradeoff I wanted to make, but some might.

item.84890

Kwan

As a further followup to my problem with Western Digital software & a reply to Joe F, I've been corresponding with WD. They confirm that without their software, there is no way administer the RAID functions of their RAID drive. The drive will still work, but I can't monitor the drive status or change the RAID configuration.

Jan. 9, 2009

item.84950

David Broudy

My 1TB MyBook Studio died last night. It spins up then stops. Ugh, but the good news is WD lets you do your own RMA online, without battling a helpdesk for same. The MyBook Studio drives also have a 5-year warranty.

Sure I'm annoyed, but drives do fail, and I have not had a drive fail in years so I guess I was overdue. Fortunately this was a backup drive, nothing lost, though this incident made me explore off-site backup via Amazon S3 for the first time, via Jungle Disk.

item.85008

Allen Ruckle

Regarding the Western Digital Green and Black drives.

I purchased a 1TB WD Green drive for an external e-sata backup drive and two 1 TB WD Black drives as internal drives in my Mac Pro. I use one of the Black drives for startup.
I also have two WD 750 Gig Blue drives internal.
With all five drives running there is virtually no drive noise from any of them.

I cannot say that about my Seagate drive or Maxtor drive.

Using the AJA System test program to benchmark the drives the Green Drive scores about 82 MB/sec read and write.
the Blue 750 drives score about 86 MB/ sec. and the Black drives score about 94 MB/ sec. I am very happy with the silence of my system especially since I previously owned a G5 2.5 Ghz Dual which produced quite a lot of fan noise.

I plan to continue to purchase Western Digital drives in fact I am going to be ordering a couple of WD Green drives to install in my new Drobo.


Jan. 30, 2009

item.86286

MacInTouch Reader

I'm using a Western Digital My Book Mirrored drive. I formatted it for the Mac, and all seems to be working fine including with Time Machine.

Because of reports here, I decided NOT to use the WD software. However, as I load data on it, how do I know that both of the mirrored drives are working, and if one fails in the future how will I know it?

Thanks.

Jan. 31, 2009

item.86326

Old Toad

This is for James McMahon and the Seagate upgrade issue. Would a NewerTech USB 2.0 Universal Drive Adapter work for you with your iMac? I haven't followed the issue that closely so don't know if connecting the sata drive thru this adaptor would do the trick. Worth a look see, however.

[I have both the Newer adapter and the Thermaltake BlacX dock and much prefer the Thermaltake, for what it's worth. The Newer adapter seems like a bit of a kludge, although the BlacX only does SATA, while the Newer Tech device handles PATA, as well. -Ric Ford]

Feb. 2, 2009

item.86405

Greg Chesney

Couple of things here -

(1) I have the Thermaltake BlacX and rotate a couple of Seagate (of the good batch) 1.5TB disks for Time Machine. I've got it coming off the internal eSATA ports and works great (except they're not hot-swapable).

(2) I've been looking at the WD Velocirator WD3000GLFS drive. Does anyone know if these fit the Mac Pro? These would be really sweet as mirrored boot drives!

Feb. 4, 2009

item.86619

Marc S

Re:

I've been looking at the WD Velocirator WD3000GLFS drive. Does anyone know if these fit the Mac Pro? These would be really sweet as mirrored boot drives!

WD3000HLFS (notice the 'H') is supposedly the drive that conforms to SATA specification and can be connected to a backplane (ie. in systems with hotswap drive bays).

http://www.wdc.com/en/products/products.asp?driveid=495 = HLFS
http://www.wdc.com/en/products/products.asp?DriveID=459 = GLFS

Feb. 5, 2009

item.86697

Julian Welch

WD3000GLFS will not connect to the main drive bays of a Mac Pro. The connectors are in the wrong place (You might get it to work in the DVD drive bay).

However, the WD3000HLFS will, and works fine.

Feb. 7, 2009

item.86817

Arthur Kent

I just saw this on dealmac.com:

http://www.newegg.com/Product/Product.aspx?Item=N82E16822136296&nm_mc=AFC-DealNews&cm_mmc=AFC-DealNews-_-NA-_-NA-_-NA

150 Gigabytes is still more than I need, but I am salivating over getting a faster drive. If I do purchase one, I could use my current internal Seagate 7200.9 250 Gig drive as a backup (along with my external 160 Gigabyte drive).

I do have one question, though. The "lettering" for this drive, HLFS, is the same that is stated above for a 300 Gig drive, according to this post by Julian Welch:

"WD3000GLFS will not connect to the main drive bays of a Mac Pro. The connectors are in the wrong place (You might get it to work in the DVD drive bay).
However, the WD3000HLFS will, and works fine."

My one question is that the 150 Gig drive from newegg is actually a 2.5 " drive, enclosed in a larger heatsink that fits into a standard 3.5" drive bay. Is that true? And, thus, will it be simply "plug in" the drive (after, of course, opening my MacPro, and following the other instructions)?

Also, I would re-format the WD drive with Disk Utility, and then use my MacBook Pro (via Target Disk Mode for the MacPro), along with Retrospect, to do a restore of the final backup on my external drive from the current Seagate drive (would I need to remove the Seagate Drive temporarily, until the backup is done?). Will that work OK?

Feb. 9, 2009

item.86848

Stephen Szewczyk

re: Arthur Kent

Yes. WD Velocirpator drives use 2.5-inch platters.

The WD3000HLFS is a backplane-ready version of the Velociraptor drive that allows you to mount the drive directly to the Mac Pro drive sled. The standard VR's data and power ports do not line up, so ensure you get the backplane-ready version.

WD also offers a bare version of the VR - WD3000BLFS for use with aftermarket solutions such as MaxUpgrades offset sled and heatsink kit for the Mac Pro [here].

Disk Utility works fine for formatting VR drives.

Note: You cannot remove the factory heatsink and put a VR drive in a MacBook/MacBook Pro. The form factor is not compatible.

If you want to get an idea of what kind of performance you might expect from a pair of Velociraptor drives in a Mac Pro, look here... http://barefeats.com/hard106.html

Impressive!

Feb. 10, 2009

item.86916

Arthur Kent

Thanks for the advice, Stephen. I was not planning on installing the WD1500HLFS in my MacBook Pro! The heat would be unbearable! I will put it in my Mac Pro.

Also, the combination of a WD1500BLFS drive and the heat sink from MaxUpgrades would be significantly more expensive that the drive and enclosure from newegg. But, I appreciate the information.

I will be ordering the drive from newegg either today or tomorrow. It will definitely be a pleasure to use a faster drive. The booting process now is, at times, frustrating, as also in running some applications (specifically, Entourage, Word, and Excel).

Mar. 17, 2009

item.89033

MacInTouch Reader

I'm not sure if this adds to the discussion or not regarding bootability issues discovered with Western Digital drives (PPC machines in the past), but WD seems to be saying that they don't support booting a computer from one of their drives, period, and that this is a change in policy. To me, that sounds like I should advise our campus computer store to discontinue them.

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=1059

Background:

http://forums.bombich.com/viewtopic.php?p=54235#54235

http://forums.bombich.com/viewtopic.php?p=54234#54234

http://forums.bombich.com/viewtopic.php?p=44639#44639

item.89124

Grandy Pollo

MacInTouch Reader sez:

I'm not sure if this adds to the discussion or not regarding bootability issues discovered with Western Digital drives (PPC machines in the past), but WD seems to be saying that they don't support booting a computer from one of their drives, period, and that this is a change in policy.

Readers should note that this link to WD FAQ refers only to their external drives and not WD drives in general (e.g. internal SATA drives which are heads and sholder better than Seagate's latest disasters) which is pretty easy to infer.

I think the track record of the MyBook and other WD external drives in the past has been pretty marginal depending on the drive and version. I would not buy their drives at all for use as data drives, for backup or anything else, let alone boot from them.

But if they do work when plugged in, their USB or FW drives should boot as much as any other drive assuming you have not interfered with the basic functionality like using their software which is completely unneccesary.

Mar. 18, 2009

item.89126

Arthur Kent

Re:

I'm not sure if this adds to the discussion or not regarding bootability issues discovered with Western Digital drives (PPC machines in the past), but WD seems to be saying that they don't support booting a computer from one of their drives, period, and that this is a change in policy. To me, that sounds like I should advise our campus computer store to discontinue them.

That restriction is for their external hard drives, not their internal ones. That, of course, makes a significant difference!

item.89143

David Blanchard

It's been more than two months since I first started communicating with Western Digital support to replace my WD Pro USB2/FW400/FW800 750 GB (WD7500E032) drive. The drive would overheat and cause the computer to freeze. We are at year 2 of a 3-year warranty.

WD sent a replacement drive but it was a MyBook Studio Edition 750 GB (WD7500H1Q) and would not boot my G5 Mac. I sent it back. They sent another Studio Edition and we sent that back.

Finally they admitted that only the Pro and Premier drives would boot a PowerPC Mac so they scoured their warehouses for a refurb. Then they sent me a Premier II 1 TB drive (eSATA, USB2, FW800; WD10000C033). Although the original Premier would work as a boot drive, the Premier II does not.

Tired of all this nonsense, I have given up. We kept the WD Premier II and it will be used as a backup drive for one of our Linux boxes and we will purchase a FW800 drive from another vender.

Mar. 19, 2009

item.89169

Ronald Leroux

I partitioned my MyBook 256 GB when I got it, not thinking it has software for the Mac. I have not updated its firmware. I use the Firewire 400 port. I don't have a problem starting up from it. I don't have any other problem with the drive either. I hope this helps.

item.89177

Rich Cruse

I have to wonder if the boot problems are not specifically with WD, but with the format of the drive. You need to reformat the drive with Disk Utility and click on Partition and Options. You need to select the Apple Partition option. This is the only format Apple PPC computers are supported to boot from. The GUID partition only boots Intel Macs.

I hope this helps.

item.89184

John Baltutis

WD issues with respect to to booting external HDs amply discussed at http://www.macosxhints.com/article.php?story=20090316190817357

item.89200

MacInTouch Reader

I have been using the WD Home Edition drive for backup on a PowerPC G5 computer. Because I have a PowerPC, it is not bootable but when I upgrade to a new Intel MacPro later this year I am assuming it will be bootable based on this WD Knowledge Base article:

How to make an external hard drive bootable on a Macintosh Computer

Mar. 20, 2009

item.89220

Terrence Thompson

My two Western Digital external drives boot Intel Macs fine. One is a MyBook and the other is a My Passport Elite from Costco.

When I got them, I just used Disk Utility to partition them with GUID.

Each has a MacBook and Mac mini Intel partitions. I just used SuperDuper! to make a complete clone of each Mac on both drives. Then I update one daily. They are part of my rotating external drive backup procedure.

My PowerPC iMac is a G5 which is alternately backed with SuperDuper! to older (pre-firmware problems) Seagate drives in OWC FireWire 300/USB 2 enclosures formatted APM. They work fine too.

My work requires backups so I also burn weekly DVDs with changed info and monthly burn multiple DVDs with my home folder contents.

I had used Retrospect in the past but have found SuperDuper! to be easy and reliable for several years now.

item.89238

David Blanchard

Rich Cruse wrote:

...I have to wonder if the boot problems are not specifically with WD, but with the format of the drive. You need to reformat the drive with Disk Utility and click on Partition and Options. You need to select the Apple Partition option. This is the only format Apple PPC computers are supported to boot from. The GUID partition only boots Intel Macs...

It's a fair question to ask. The drive was erased and partitioned using APM.

WD support pages clearly state that only the WD Pro and the WD Premier external drives will boot PPC Macs. These models appear to be no longer available - not even for warranty replacement. Newer Intel models do not have this restriction.

See this WD Knowledge Base link: How to make an external drive bootable...".

See, also, this link from the developer of SuperDuper! concerning booting from WD drives with a PPC Mac.

May. 14, 2009

item.92074

Floyd [SeattleComputerFix]

Those who are interested in disassembling the 1TB WD should go to the following site: Western Digital My Book - Opening the Case - Removing the Drive

Aug. 20, 2009

item.97967

John Kyrk

As I mentioned before, my Western Digital MyBook Pro Edition II (which was also my Time Machine) frequently disappeared from the desktop and required unplugging and replugging. Then about two months ago it completely died, all backup gone. Western Digital replaced it though I had to pay the shipping charge to return the defective one.

For several months I had also I had another problem when logging into or out of various accounts: my Mac Pro would simply hang and require a hard reboot that would take 7 to 10 minutes. And every time when the desktop reappeared, the Western Digital HD would be missing, requiring unplugging and replugging. The same thing happened with the replacement unit.

Enough. I bought an Apple Time Capsule about a month ago for Time Machine backup, and the problem has not reoccurred.
I would never use Western Digital as a Time Machine.

Aug. 21, 2009

item.98011

Dan Rempel

I've had similar problems that seem to be caused by WD drives, but its difficult to actually _prove_ it's the drives. Assuming it is, I think the problem is their power management features and something in OS X's device drivers simply don't get along.

item.98047

Skot Nelson

Re:

I would never use Western Digital as a Time Machine.

Whereas I've been backing up to a Western Digital MyBook through USB since the day Leopard launched, with no complaints. The backup started on my PowerBook and is now backing up my iMac.

Aside from the fact that it's a bit small (500GB, the iMac drive is 320 but only has 150GB of data on it) it's performed well enough that I've forgotten if I've had the occasional non-mounting problem...which I'm sure I have, now that I think about it, but not often and obviously easily solved (probably by a reboot.)

item.98050

David Broudy

Well, the dual-drive WD units are pretty flaky. But pretty much any consumer-grade dual-drive unit is asking for trouble.

I have three WD Mybook Studio drives connected via FW800. No problems. They do seem very sensitive to electrical power, and I fixed an issue with spin-up failure by removing the $1.99 IKEA power strip I'd been using and plugging them directly into my UPS.

Aug. 29, 2009

item.98588

Curt H

I have 2 WD Passports connected to my MacBook Pro, one 400gb Studio (WD4000MT) via FW800 which i use to store my iTunes music, and another 320gb (WD3200MLZ) via USB 2.0 for Time Machine. I've had this setup for about 4-5 months and i have a recurring problem which i can neither solve nor gain any insight from FAQs or Knowledge bases whether WD, Apple, or other sites.

As the Passport Studio stores my music, it behaves erratically sometimes. For example, with iTunes playing music, the device connection will fail and I get an error that the device wasn't removed properly, etc, etc. I thought it may be the FW800 connection, so I tried it with FW400 with continued intermittent failures, as well as USB 2.0 with the same results.

I updated to the most recent WD Drive Manager version as well as the updated Turbo drivers too... no change.

Anyone experience this similar issue? Any solutions? Or do i have a bad drive?

item.98701

MacInTouch Reader

Hi Curt,

I commented on this before, but can't find the posts, so I'll risk repeating myself.

WD drives' energy-saver/powerdown behaviour seems cause problems like you describe; other problems include hangs when logging out, restarting/rebooting, or waking from sleep. I haven't been able to track down exactly what's happening, but I no longer see the problems now that I unmount the drives and physically disconnect them from my iMac when they're not in use. I don't power them down, and they re-mount with no apparent problems when I plug them back in.

Hope this helps,

Dan

item.98713

MacInTouch Reader

I had the same problem with a 1TB hard drive from OWC that started about a month and got worse over time. I blamed it on Time Machine and could not figure it out until the hard drive went out completely and had to send it in yesterday. I tried to running checks on the hard drive but nothing ever showed up.
It would disconnect like yours at random times whether connected to Airport extreme or connected with firewire or usb cable. I was told by Other World Computing tech the hard drive went bad and send it in, lucky its under warranty. Hope this helps

Terry

item.98718

Davide Guarisco

Sounds like a possible power supply problem.

item.98749

MacInTouch Reader

I use one 500 GB Western Digital Passport Elite from Costco last fall for cloned SuperDuper! backups for a MacBook and a Mac mini.

It is USB only. I initially reformatted for two GUID partitions and HFS+ journaled.

Both backups boot flawlessly and I have no problems updating with SuperDuper! or using the partitions as boot drives.

I'm happy with USB 2.0 as the FireWire 400 ports keep failing on earlier USB 2.0 FireWire 400 external drives or USB 2.0 FireWire 400 drive enclosures that I've purchased over the past three years.

FireWire is a nuisance for me at this point. I only use it for older G5 Macs and a older Sony digital camcorder.

item.98765

David Atherton

Despite statements by Western Digital on their website to the contrary, my Passport Studio will only act as the startup disk if I connect it via USB. If I use the FireWire connection, it is not bootable. This is a HUGE limitation and WD won't own up to the problem.

Aug. 31, 2009

item.98803

Linda Custer

I have a WD PP III Studio II that I got earlier this year to use over Firewire 800 to my MBP (Late 2008). It holds my iTunes and iPhoto libraries. I had the same problems reported by earlier contributors to this thread: the disk would die and require a re-boot. It was very unreliable.

I went on the WD website and upgraded the drivers (just by +0.0.1 from 1.0.4 to 1.0.5), and this solved the problem under Leopard. The problem might or might not have started after the 10.5.8 update. It was very repeatable, and never occurred again after the driver update.

Now I'm running Snow Leopard 10.6 with *NO* WD drivers, and the problem has not come back.

I'm leary of any drives that don't use Apple's internal drivers. If I had it to do over again, I never would have installed the WD turbo drivers at all. They're not necessary -- just claim to give a small speed increase.

item.98958

Michael Penland

Another WD question:

I have a Western Digital My Book Mirror Edition 2TB USB 2.0 drive.

I heard about problems using the WD drivers so simply plugged it into my iMac. It shows up as a 1TB drive, does this mean there's no way to access either the mirroring, or the full 2TB capacity, without using the WD driver?

Is the WD driver safe to use?

Is this type of drive safe to use with Time Machine?

Thanks.

Sep. 5, 2009

item.99417

Norman Hester

I have 3 WD FireWire drives connected to iMac. After installing OS X 10.6 the Console repeated this message every 10 seconds irrespective of whether the external drives were ejected or not:

9/3/09 6:20:54 PM WDDriveManagerStatusMenu223 *** attempt to pop an unknown autorelease pool (0x838800)

I have asked WD for advice (still too early), but in the meantime WDDriveManager is now residing in trash, and all appears normal!

Does anyone know whether the WD Drive Manager serves any useful purpose on Macs?

Sep. 8, 2009

item.99517

Sterett Prevost

Re: Norman Hester & WD FireWire drives

I'm almost certain you installed WD's "one touch" software at the time you put those drives into service. With one of my clients I had to search all over their drive and remove all the scattered pieces of that poorly-written software, since he was experiencing a significant slowdown; after I removed all of the pieces, his Mac returned to normal. Contacting WD may not be worthwhile, as I think the "one touch" feature is basically aimed at selling drives to Windows PC users, even though Mac compatibility is claimed.

Sep. 9, 2009

item.99716

Doug Unruh

I had the same problem [as RJ Gulyas had with a LaCie drive] with a Western Digital drive. It seems that I had the wrong power supply connected to the drive. (I have *many* power supplies from prior devices.) Once I found the proper power supply, all was working fine. However, another WD drive did exhibit the clicking sound [and] didn't respond to the replaced power supply. WD replaced this drive with no problem.

item.99782

John Baltutis

See WD's response to a query on which of their ext HDs are bootable:
WD external hard drives that are Mac bootable and how to format them to install an operating system

Mac computers can use WD external drives to boot into the Mac OS; however, not all WD drives can boot both Intel and PowerPC Mac computers. Below is a complete listing of modern WD drives tested to boot into the Mac OS. The tables separate drives based on their interface (USB/FireWire) and capability to boot Intel or PowerPC Mac computers.

Dec. 7, 2009

item.105703

Andrew Hedges

I have 2 Western Digital (WD Elements) external drives. I have partitioned both drives using Disk Utility and they both exhibit extremely slow transfer speeds and, in the case of the slightly older drive, a failure to completely mount both partitions.

I searched around and found a firmware update (http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilitiesmac), but it appears only to apply to WD Essential and Elite drives, not Elements drives.

Anyone know of a fix for this problem? Is there a firmware update I'm missing in my searching around?

Dec. 8, 2009

item.105764

David Krafchick

Andrew

My brother bought me a WD Element 1 TB USB. Until this drive, I used Firewire drives (40 switched out with 80, another 80 and a 250 gig). It was very slow as well. I traced this to the 32 Fat software that allowed it to work on Macs and Windows.

I used Disk Utilitiy to initialize the drive and replace it with Mac Extended Journaled and everything improved. This should solve your problem.

item.105770

Adam Barisoff

If you're referring to the portable 2.5" Elements drive, you could just do what I did - open up the case, pull the internal drive (a Scorpio Blue) out and place it in an inexpensive Firewire enclosure, like this Macally PHRS-250CC on Amazon. Presto - instant 2x speed increase (assuming you have Firewire).

(Strangely, the Elements USB drive was cheaper than a bare drive of the same capacity.)

item.105776

Randall Voth

Andrew Hedges - Have you tried a different cable? Could you have somehow attached them to a USB 1.1 interface instead of USB 2.0? Use System Profiler to check whether it is attached to a "High-Speed Bus". (Press Option while clicking the Apple menu for the Profiler). Use Activity Monitor to check hard drive speeds using the "Disk Activity" tab while copying a large file. USB drives should be around 15-30 MB/s, depending on the drive's speed.

Dec. 9, 2009

item.105836

Paul Huang

Harvesting the drive from Western Digital Passport (or other external drives):

Generally speaking, drive makers package their own drives into their own enclosures and sell them as an external drive. As another MacInTouch [reader] pointed out, the internal drive is priced lower than the external drive that contains the identical drive. For a while, I have been 'harvesting' those drives from the external units.

Knowing that companies generally voids the warranty as soon as you crack the case, I still went to WDC's site to process an RMA. I sent in the bare 2.5" drive and received a refurbished drive enclosed in an external case. Apparently WDC tracks the serial number inside the enclosure (or the two numbers are linked, so they know what the bare drive came from an external unit). I have not opened the case to see if the drive is indeed refurbished.

Another incident was Iomega. I sent in the drive (Seagate 5400.6 drive enclosed in the original Iomega aluminum FW400/USB 2.0 case... the old rectilinear case, which is easily to disassemble with two screws, not the plastic 'helium' drive) for 'repair'. I received the drive back and it has a 'refurbished' label on it. I opened it up and it has a new Seagate 5400.6 drive inside.

Dec. 11, 2009

item.105938

Bradford C. Riendeau

Like some others who have posted on the web, I purchased a Western Digital 1 TB drive recently. Western Digital has included something called Smartware in its firmware which appears on the desktop as a "virtual cd." The "Smartware" cannot currently be removed with ordinary tools. It interferes with the ongoing operation of Time Machine. It uses up disk space which makes the drives usable size significantly less than advertised. I am fearful that it makes the drive fundamentally unreliable, although I cannot confirm this. Western Digital's tech support people have not been helpful thus far. Smartware appears to be a recent development, as older drives have a very good reputation. The problematic nature of "Smartware" appears to be cross platform.

item.106036

Daniel Griscom

Western Digital has posted directions for enabling/disabling SmartDrive:
   http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilitiesmac

item.106038

MacInTouch Reader

There are instructions at the Western Digital site for disabling the virtual CD:
  http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilities

Dec. 14, 2009

item.106048

Michael Fryd

A MacInTouch reader wrote:

There are instructions at the Western Digital site for disabling the virtual CD:
    http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilities

My solution to the mandatory Virtual CD was more straightforward. I returned the opened drive to Best Buy and got a full refund.

When consumers vote with their pocketbook, manufacturers listen and change their products.

When we whine and complain, but still buy the products, manufacturers simply change their marketing and support.

If you don't like a product; return it.

If the product doesn't work as advertised/expected, demand a full refund.

Dec. 23, 2009

item.106617

MacInTouch Reader

I'm the chief tech guy at a company that writes music for commercials. We have offices in NY, LA, London, and Paris, so I manage many Macs and Mac servers.

For our main servers we have been using High Point Rocket RAID 3522 SATA RAID cards, supporting 8 drives. These are some of the only affordable cards that I have found that support RAID 6 - you can lose up to two drives with no data loss. High Point' support is less than stellar, but the cards have been working fine for over two years with arrays containing a mix of Hitachi and Samsung 750 GB SATA drives. One card died about a year ago, and I was sent a replacement by my vendor (Granite Digital, whom I do recommend for their support).

A few weeks ago I decided to upgrade my arrays. I shopped around and found Western Digital "Green Caviar" 1.5 TB drives (model WD15EADS) for a great price ($110 each). I ordered 30 of them. Then the nightmares began.

Frequent crashing, kernel panics, channels not being recognized - that's channels, not the drives themselves. No amount of swapping cables would change it once the channel would disappear. I got another 3522 card thinking that was the problem. I finally got one to work, but the rebuild was so slow it did not finish in the week that I spent trying to migrate the data to it. The crashes caused data loss, and were the result of the 3522 simply "disappearing" - that is, the system suddenly did not know it was installed. Once the array was "up" (although not fully initialized, which was going on in the background), performance was dreadful. It took 1 hour to copy 10 GB of data from an internal drive to the aray (The servers are 4 core Mac pro 2.66 ghz, not xserves). High Point support was not able to help me solve this, I finally called Western Digital. They told me that these drives are not suitable for RAID arrays due to something called "deep recovery mode" (I'm not sure if this is the same as "smart drive" or not), which causes most RAID cards to think that the drive had failed. WD refused to exchange them. There is no warning of any kind on the labels or in the literature. On the other hand, the on line vendor (in this case not Granite Digital, unfortunately) will take them back, but for a restocking fee - since I bought 30 of them, that is somewhat of a relief. However, I don't know why they would charge a restocking fee for some drives I haven't even unpacked yet.

WD says they should work as internal drives in Macs, but performance seems to be very poor in that case also. WD also says that there is a Green Caviar drive that is supposed to be suitable for arrays, but I can't find any for sale anywhere. In any case, I will not buy from them again.

Thanks for hearing out my rant. I would be very wary of buying these drives for any use at all.

Dec. 24, 2009

item.106727

Constantin von Wentzel

FWIW, I have had no issues with the 2TB version of the WD Green series, i.e. the 20EADS, when used inside a Netgear ReadyNAS; ditto for the current consumer 2TB made by Hitachi. That said, perhaps I haven't been able to trigger deep recovery mode yet, or the ReadyNAS firmware isn't fooled by the WD misbehavior. This sort of drive behavior wasn't a problem in the past, as best as I can remember, so one wonders if drive vendors are intentionally sabotaging retail drive firmwares to improve margins by charging between 30-100% more for a "Enterprise" drive vs. a standard retail drive.

I guess I'd feel better about paying a significantly higher retail price for a "enterprise" drive if differences were apparent. Claims about MBTF are nice, but no drive vendor has opened their kimono to disclose actual failure rates. Typically, warranties are similar, as is on-board memory, throughput, etc. When used in a NAS, none of these drives appear to be stressed re: performance as the gigabit ethernet connection becomes the bottleneck. For example, the EADS20 drive easily achieves 70MB/s transfer rates when attached to the SATA bus, a single ethernet connection maybe makes it up to 1/2 that.

What it comes down to is having multiple, redundant backup options. NAS's are relatively inexpensive compared to the data stored on them. So buy a couple, distribute them all over the place and use Rsync + SSH tunnels to back up the work drives incrementally on a regular schedule. On a weekly basis, use external drives to manually backup the RAID array, store off-site, etc. The Qx2 from OWC is pretty ideal for this when used with a ReadyNAS like the NV (connect USB cable, push a button, wait a few hours, done).

Lastly, a bit of good news from OWC regarding the ESATA Expresscard / Voyager Dock issue. A manager very kindly called me yesterday to let me know that neither the Expresscard nor the Voyager dock will incur a restocking fee if the tech support folk at OWC cannot resolve the drive zeroing issue. So, good news and I appreciate the time and effort they're putting in and yet another reminder why I have bought a bunch of gear at OWC over the years.

item.106729

Michael Fryd

A MacInTouch reader commented on "Deep Recovery Mode" and Western Digital Drives.

One of the firmware differences between desktop and RAID qualified drives is how they handle errors.

On a desktop drive, your data is very important. If the drive gets a read error it can spend over a minute in "Deep Recovery Mode" in an attempt to recover your data. During this time the drive is unavailable.

In a RAID environment, the RAID controller will notice that the drive stopped responding, and will consider it to have failed.

For RAID "qualified" drives, the firmware is adjusted to spend only a few seconds trying to read a problem sector. The drive returns to service quickly enough that the RAID controller doesn't give up on it. Data loss isn't as critical an issue as the RAID probably has a duplicate of the info.

Western Digital refers to the behavior as "TLER" (Time Limited Error Recovery). You can read more about this at   http://en.wikipedia.org/wiki/Time-Limited_Error_Recovery

Apparently on some WD drives you can adjust this parameter with a utility program, converting a Desktop drive to a RAID drive.

Dec. 28, 2009

item.106804

Harris Upham

I'm just curious about the next layer in...

If you have a traditional disk which enters a deep recovery mode and "fails out" on your RAID controller, then your controller knows that the RAID is in a degraded state and can proceed with a rebuild into a spare drive once one is available.

But a disk with TLER behavior would never error out the controller. If the block fails to eventually read, then the disk has arbitrarily placed the RAID into a degraded state *without the controller being aware of it*, which is a very dangerous condition.

I'm guessing there's a new mechanism for a TLER drive to notify a RAID controller that a mirror is out of balance due to an unrecoverable block, but I don't know what it is and it sounds like a good thing to know about. Any takers?

Dec. 29, 2009

item.106845

Michael Fryd

Harris Upham asked:

...But a disk with TLER behavior would never error out the controller. If the block fails to eventually read, then the disk has arbitrarily placed the RAID into a degraded state *without the controller being aware of it*, which is a very dangerous condition.

I think you have it backwards.

RAID qualified drives (with the TLER feature) generate an error when they can't read a block. The RAID controller sees that the read failed, and regenerates the data using redundancy from other drives.

Consumer/desktop drives can spend over a minute trying to read a bad block. If successful, the drive returns the data without error. The computer doesn't realize that a problem has occurred (other than the drive took a long time for the read).

Of course, this is merely what the drives do. It's up to the controllers to decide how to react to these conditions. I would expect that a good RAID controller would pay attention to the drive's SMART diagnostics, which should track this sort of thing.

Without TLER, the RAID controller may decide that a drive is dead, when it merely has a bad block. A few bad blocks don't necessarily mean that the whole drive is bad. However a steadily increasing number of bad blocks suggests that the drive is failing.

Jan. 12, 2010

item.107508

MacInTouch Reader

I have a Mac running Tiger 10.4.11. I recently bought a brand new WD Elements 1 TB external HD but I'm having trouble formatting it. It shows up in Disk Utility but when I try to partition it I get the following error:

"Partition Failed. Input/output error"

I've tried partitioning the drive as "Mac OS Extended (Journaled)" using the Apple Partition Map to no avail.

It's frustrating because, judging by most message board threads, this seems to have worked for a lot of people who have seemingly had the same problem as I do.

Studying the screen shots on WD's Web site, the only differences between what shows up in Disk Utility for me and what WD says should show up are the following:

WD's screenshot shows a volume called "DRIVE" in the left hand panel underneath the external HD icon. Mine does not show any volume.

Also, WD's screenshot shows that the Partition Scheme is "Master Boot Record," but mine says the Partition Scheme is "Unformatted."

I'm totally stumped. Any suggestions?

item.107563

Don Gillespie

Re: MacInTouch reader... Partition Scheme is "Unformatted."

Have you tried to "Erase" the drive in order to format it, first, before tring to partition it into volumes?

item.107572

David Krafchick

Reformat the Drive in Disk Utilities with Journal Extended. It is formatted to work with Windows and Mac with 32 Fat drivers. Reformatting will solve your problem.

I know. It happened to me.

Jan. 13, 2010

item.107598

MacInTouch Reader

It's been so long that I don't remember all the details any longer but back when I started using a WD 1TB Essentials drive for backup, I had no end of trouble with it, including, I think, formatting. It turned out that I'd been running Disk Warrior's Hardware Monitoring in automatic mode, but even though it was set to only check once a day, it seemed to be maintaining some kind of continuous connection to the drive even though it couldn't monitor the SMART status of the USB connected drive in the first place. As soon as I turned automatic monitoring off, the WD Essentials drive simply worked. I believe that Disk Utility conducts the same SMART test that Disk Warrior does, you just have to do it manually; of course that still doesn't include the WD Essentials drive.

item.107604

Bill Ware

I was unable to get Disk Utility to erase (and reformat) a 2TB MyBook Essential with packaging that indicated it must be reformatted for use with Mac OS X. However, a WD drive app eventually showed up in a WD virtual CD in the Device listing in Finder's Side Bar. The app asked if the disk would be used with Time Machine. Only after clicking yes did the volume show up as being Mac OS Extended (Journaled) in Disk Utility. Very confusing.

item.107608

Tracy Valleau

How to format a Mac drive:

http://mactips.valleau.net/?p=58

Hope this helps.

May. 17, 2010

item.114557

Ben Segal

Hello all -

Perhaps someone here can help me figure this out.

I bought a new WD Elements 2TB drive. I am currently running 10.5.2, and want to update to 10.5.8 in anticipation of my iPad. But want to do a clone of my drive first, and all my old disks are full.

Understood I would have to reformat it; no big deal. Opened it up, plugged it in, and Disk Utility refused to reformat it because it was "read only". I tried a number of things - using an admin account, restarting, fixing permissions on my system - all to no avail.

Plugged it in to a different Mac (running 10.5.8) and had no problem formatting it and then copying a file to it. But even after that, my system saw it as read only.

WD tech support was nice, but ultimately unhelpful. I posted on their site and they called me back within 15 minutes. After a short talk, they were out of suggestions except returning it for a new one.

The new one has now arrived. Plugged it in to my system and [had] the same problem. Disk Utility will not format the disk because it is read only.

Anyone have any insight into what might be causing this problem, and even better, what might be a solution?

tia and thanks as always to MacInTouch

item.114577

Colleen Thompson

Ben Segal wrote:

..."I bought a new WD Elements 2TB drive...Disk Utility refused to reformat it because it was "read only"...The new one has now arrived. Plugged it in to my system and [had] the same problem. Disk Utility will not format the disk because it is read only."

Launch Disk Utility, highlight the problem drive (the hardware line, not the indented volume line) in the source column on the left, and look at the bottom of the window. What is the partition scheme?

It's possible to *format* for Mac on top of a Windows partition (Master Boot Record). This might be the cause of your problem. If you were only formatting or "Erasing" it before, try partitioning it.

Click on the Partition tab in DU (again, you need to have the correct hard drive selected in the source list; if you highlight the volume instead, you won't even see the Partition tab); under Volume Scheme, pop it up and choose 1 Partition; click on Options and choose GUID (if you have an Intel Mac) or Apple Partition Map (if you're PPC), and partition away, which will also format as part of the same process (choose Max OS Extended Journaled).

May. 18, 2010

item.114588

Don Hirsohn

Go to Disk Utility. Select the drive. Go to Partitioning. Select to create 1 partition. Click Options. Select GUID as the partition scheme. Then apply. Now your drive should be read/write.

item.114595

Ben Segal

Although I appreciate Colleen Thompson's suggestion... However, to be clear, I have already tried what Colleen Thompson suggested. Disk Utility will not allow me to partition this hard drive. On the bottom it lists "Write Status" as read only. The various options in the partition tab are greyed out and on the right side of the pane, just under the volume info (on the partition tab) it says "This disk is not writable and can not be partitioned."

Yet when attached to a different machine, I have no troubles

item.114604

MacInTouch Reader

To Ben Segal: Use the "get info window" to change the permissions of the drive or the volumes.

item.114625

Brad Riendeau

The story of dealing with WD tech support sounds awfully familiar. I purchased a WD passport drive just before Christmas. WD has a proprietary disk formatting and backup system that is locked into the hard drive and cannot be removed. You can reformat the drive as often as you like, but the backup system is like Hotel California. You can't get rid of it. The better route is to go Amazon and buy and enclosure and one of WD's OEM green drives. They don't have the built in backup software. WD's has a couple of product streams and they have optimized their consumer line for the other 89% of the market. Call WD and scream and yell.

item.114626

David Krafchick

As Colleen wrote, that's one way to look at it. I have a 1T WD which came 32 Fat, which was slow as a snail. I reformatted it to Mac [HFS Extended] Journaled and it worked fine, except if you accidentally tap it, the power or USB cable (which only goes in half way, slips out. I now only use it for video archiving.

As for the 2T, I am surprised that WD techs do not know how to service Macs. I was the one who diagnosed and reformatted, then called back and shared the solution. So, I guess this is not that important to WD.

item.114628

MacInTouch Reader

I have a Western Digital Essentials, I believe it is. I've been using it for a couple of years as my Time Machine backup. Just recently it mounted as a read only drive and as I tried to verify it, something showed up wrong in the B-tree. Now I can't even mount it, but the Finder will keep on trying. I guess it is now a paperweight.
Thanks,
Rodney

item.114631

MacInTouch Reader

Ben Segal's problem might just be a permissions problem. Try checking the "Ignore ownership on this volume" box in the Get Info window. If this helps, you can click on the Sharing & Permissions triangle and reset the permissions to your liking.

item.114642

Ben Segal

Thanks everybody for trying to help. This has certainly stumped me.

Today's suggestions regarding permissions have also been attempted. I was unable to change permissions (through the finder or terminal) because the disk is "read only".

I even tried changing the permissions on a different machine. The changes worked, but then connecting the drive to my machine it was still identified as "read only"

"Ignore ownership" is checked. Doesn't seem to matter.

I am pretty convinced there is something wrong with my system, since the drive works fine on the other machine. Trying to figure out if it's a 10.5.2 anomoly that will go away when I upgrade to 5.8, or it is something bigger, and I should just erase my system drive and start over.

The weird thing is, this machine has two other drives attached and they work just fine.

Any other suggestions?
tia,
ben

Next Page...


MacInTouch Amazon link...

Talk to MacInTouch     Support  •  Find/Go