MacInTouch Reader Reports

Leopard: Update 10.5.7

May. 13, 2009
May. 14, 2009

Newer entries...
May. 13, 2009

item.91953

MacInTouch Reader

I tried to download via software update. After a whle, I was alerted that the update couldn't be saved:

"The digital signature for this package is incorrect. The package may have been tampered with or corrupted since being signed by "Apple"."

This happened twice. I guess I'll wait a while.

item.91955

William Frank

Had to use the MacInTouch-provided link to get to the Combo download, as a search on 10.5.7 at the Apple website provided zilch. Software update didn't know about 10.5.7 yet either. I remember to do a full Repair Permissions on the hard drive just to be safe, then did the Install. Upon rebooting (on a 2009 White MacBook, with 6 GB Ram and 500 GB HD) it got half way through the reboot, and rebooted itself a second time which scared me, but I crossed my fingers and all went well. The 10.5.7 provided the Safari update; and so far all seems OK.

item.91956

David Green

Just installed the 10.5.7 upgrade on a Mac Mini (my "staging" upgrade machine), using the Combo updater. When the download was complete, I clicked the Restart button, and the system got stuck in a cycle between the blue screen and a screen filled with lines and lots of de-rezzed "snow"/"noise". Every few cycles, the "time circle" indicator appears, then it returns to the de-rezzed screen.

After powering down, then back up, after two or three restart chimes, the system seems to be OK.

I think I'll wait a while before installing 10.5.7 on my "working" machine.

item.91957

David Luckhardt

The 10.5.7 combo updater put my previously stable 10.5.6 Mac Pro into a continually-restarting loop, and had to be manually turned off by pressing the power button.

After restarting and updating Safari beta to 5528.17 via Software Updates (requiring another restart), all seems OK again at this stage.

item.91958

David Wolfe

After backing up and running Cocktail, I installed the OS 10.5.7 combo (never the update). It restarted twice as expected. The first problem I experienced is that my wireless mouse failed to work. Using a wired mouse I installed Safari 4 Beta followed by a restart. The wireless mouse then worked, probably because of the third restart. Unsuccessfully tried to print on a Samsung ML-2570. Reinstalling the print driver fixed that problem. Using Disk Utility, repaired the permissions (lots of them). Everything seems to be snappier. The Safari 'show all sites' is a useful addition.

item.91959

Bill Barstad

No problems upgrading my 20" late 2006 Intel iMac. Took more than 10 minutes to install and rebooting was slow, as expected. All my usual apps run OK.

item.91960

Tom Jacobs

I attempted the 10.5.7 update (from 10.5.6) on a Mac Pro 2.8GHz Quad-Core. About a third of the way through I got this error and could not complete the update:

The update "Mac OS X Update" can't be saved. The digital signature for this package is incorrect. The package may have been tampered with or corrupted since being signed by "Apple".

item.91961

Harold Lewis

Perfectly smooth installation here on my 2007 MBP.

item.91962

Gareth Renowden

Update finally worked here (MBP 2.4 2007 vintage), but only after Software Update process failed (reporting security issue with file). So I downloaded the combo updater (which I probably should have done first.. ;-) ), ran that, and then watched as the restart process stalled on first closedown (blue screen, occasional spinning process wheel). Eventually forced a reboot, and the machine ran through three restarts (including a boot cache process). Now seems to be working fine, after an uneventful update of the Safari 4 beta. Deep sigh of relief...

item.91963

Evan Mair

Early 2008 MacBook Pro 17 inch: Software update was *slow*, so I downloaded and installed the Combo update instead. On attempting to reboot, it entered a strange spinning loop (background would change between 2 shades of blue) that didn't seem it would ever stop. Fingers crossed, I powered off and rebooted. 3 self-reboots later (how about a warning "Your machine is about to reboot, don't worry!", Apple?), I was back up and running. Applied the Safari beta update. Working smoothly...

item.91966

MacInTouch Reader

The latest Beta update for Safari, still won't recognize the Garmin plug-in (version 2.7.1.0). FireFox does and works great. Garmin has a test page for this purpose and Safari just doesn't go there.. Maybe on the next update?

item.91968

MacInTouch Reader

Applied 10.5.7 Combo update to 15-inch MacBook Pro Unibody 2.53 GHz Intel Core 2 Duo, 4 GB 1067 MHz DDR3. Before updating I backed up, and used Disk Utility to verify disk and repair permissions. The installation went smoothly until restart when I experienced the looping blue startup screen I've read about elsewhere [Looping blue screen with 10.5.7 install]. I let this loop for about 10 minutes and then forced a shut down. When I turned the machine back on it started to boot, restarted again, and then everything was fine. I ran Disk Utility again and everything checked out just fine. I've been using 10.5.7 for a couple hours and have experienced no issues. Everything was perfect except for the blue looping restart after installation. Hopefully I will have nothing further to report.

item.91969

James Manos

Using the combo version of 10.5.7, I updated two iMacs (2006 and 2008), a Mac Book Pro (2007) and a Mac Pro (2008) without any problems.

As is my standard operating procedure, I ran disk repairs and completed clone backups of each system before applying the update.

item.91970

Peter Dy

i had a problem updating via the software update method. something with the signatures being incorrect.

So i downloaded the combo updater and installed. Upon restart, my MacBook hanged at the start up screen indefinitely. I powered it down by holding the power button. I powered it back up and the install finished albeit very slowly.

I verified the disk and it seems to be in order. As a precaution, I'm going to back things up and do a clean install...

item.91971

George Carrington

Installed 10.5.7 Combo Update without any problem on 2.8 GHz 24" iMac. Discovered subsequently that Safari 3.2.3 is included in the update, could have saved myself downloading the Safari Update. About the only noticeable change is that graphics appear "cleaner", more vibrant.

item.91972

Peter Hull

After applying the 10.5.7 Combo update, my MacBook freezes consistently the second time I put it to sleep. In other words, sleep works once, but the second time I close the lid or choose "Sleep" from the menu, it freezes before it has a chance to sleep (i.e., the screen backlight stays on, the sleep light doesn't start "snoring", etc. I have had a problem with this MacBook also freezing upon changing from wireless to wired networks (where the wireless card gets powered off) ever since Feb. 2008 (two months after buying the MacBook). The only solution is to restart before turning off the wireless; after a fresh start, it will power down the AirPort card nicely. But once the AirPort card is powered down, surprise surprise, it won't power up again without another restart. This is, to say the least, very frustrating. Has anyone else seen this happen? Is there a solution besides replacing hardware? Thanks anyone who can help!

item.91974

MacInTouch Reader

Trying to get 10.5.7 through software update in the Apple menu (MacBook Pro 1st gen) kept stalling so I downloaded the 10.5.7 (from 10.5.6) installer (from 10.5.6) from the Apple web site instead.

The installer ran okay until the very last part where the Finder disappears. At this point the installer got stuck in a ten second loop between blue screen white screen and the spinning icon.

I forced the machine to reboot (by holding the power switch) and then the machine restarted, and then restarted itself again, and again, and again . . .

Panic! So I held down Command-S and ran fsck -f. On restarting all was well. Hmmm.

item.91976

Louis Schwitzer

Last night, I downloaded both versions of the 10.5.7 update to my flat in the UK. I installed the "lite" (at 442Mb) version on a new Mini (2.26Ghz, 4Gb ram, 256Gb SSD) and had no problems. This morning I installed the "large" version on a 2.33Ghz 17" MacBook Pro laptop (3GBb RAM) with no issues.

I was not so fortunate with a remote installation back in Phoenix on a spare (operating system 10.5.6 with TB2) CoreDuo Mini in my server area. Using Timbuk2, I downloaded the "lite" version and the install went as expected. After hitting the restart button, the connection of course quit. As it was late and I knew it would take some time, I retired. This morning, I cannot establish a Timbuk2 connection with that system. Ping did not show that anyone was home. Thus, I decided the rest of the servers will await my personal presence before doing any OS updates.

I have stayed away from Safari 4 beta to date.

item.91978

Jess Have

After installing the update proposed in the Software update, my Mac switched off without warning. MacBook Pro (2006)

item.91979

Tom Ledbetter

My first attempt to download the updates using system update failed saying something to the effect that if was corrupt.

Second attempt worked but the system froze on the install /restart with the status bar about 1/3 of the way complete.

I forced a shut down and upon restart if says the system is updated. Is it?

item.91982

Nate Goldshlag

This was the first disastrous update for me. When I closed my MacBook Pro it did not go to sleep, the backlight was still on, and the machine was frozen with no cursor. I had to hold the power button to turn it off. I tried zapping PRAM and deleting caches to no effect. In the end I had to go back to a 10.5.6 Super Duper clone of my disk. My wife, also with a MacBook Pro, is not having this problem.

item.91984

Dana Baggett

I installed Mac OS 10.5.7 using the update offered via Software Update. The process went rather slowly - lots of time spent looking at a stopped progress bar - but I refrained from interfering. It eventually completed the installation and after a now familiar double boot up, all is well.

item.91985

David Bergum

When I updated using the combo updater on an old PowerBook G4, I noticed the expected double reboot, but since I use verbose console mode on boot, saw *lots* of log messages of errors and failures. When I first logged in, it hung with my desktop picture and was unresponsive. After waiting a while, I forced shutdown and restart, still lots of messages in the log, held my breath, and was able to login and function as normal. I soft rebooted, and the startup log looked normal.

However, I am seeing these messages every 8 seconds now:

May 13 07:47:13 DIB mDNSResponder[17]: handleLNTGetExternalAddressResponse: Router returned bad address

I can unload the mDNSResponder using launchd as described in other sources, but then I get a mess of other errors from stuff tying to use Bonjour. So I live with the errors. I tried a cardbus 802.11n wifi card on the off chance it was my internal Airport, but makes no difference.

Anyone else see these log message and have a clue what is going on? I have a Siemens DSL router with an Airport Extreme in bridge mode. I should probably figure out how to get the WAN port to work on the Siemens so I can run my Airport in non-bridged mode and see if that helps.

item.91986

Alex Weir

Downloaded the Combo and the shorter Update for future reference, then used the Update procedure that comes with Leopard.

It took awhile and it rebooted three times before it finally was all installed and I continued on, but decided to backup to Time Machine, and that is when the system crashed. This is only the second time in two years that I have seen this since converting to the Mac platform from Windows.

Since then it's performing as usual and I completed the backup to TM.

The one problem that Apple could have fixed before the update installed it's self was have the Updater install the new Safari, since the new version won't install now as well as the security update they released simultaneously

item.91987

Nicolas Martin

I used the combo update, and it eventually stalled with the gear icon spinning endlessly. I forced a shut down using the power button, and then upon restarting the Macbook auto-rebooted twice before the desktop appeared. So far I have no problems, but Apple sure muffed this one. There are many reports of install problems. This is so obvious that it points to a glaring quality control problem at Apple.

item.91988

David Janik-Jones

My experience exactly mirrors that of Gareth Renowden and Evan Mair. Blue screens of nothing for an hour before I simply powered my new unibody MacBook off, three self restarts etc and back to normal. That was the worst update I've done since 10.0.3 I think. Ugh. YMMV.

item.91989

Brad Koehn

10.5.7 appears to finally fix the bug in Mail which would, if you left Mail running long enough, create dozens of zombie "AddressBookSync" processes, eventually preventing Mail from functioning correctly at all.

See Mail causing zombie AddressBookSync processes for more background on this issue.

item.91990

Fred Remley

My 2007 Macbook Pro exhibits the same behavior as noted by Peter Hull. It locks up on the second sleep, as Peter describes. Still working on it; any suggestions?

item.91991

MacInTouch Reader

Found the combo downloader without any problem, updated my Dual 2.0 PowerMac G5 with all sorts of peripherals and all seems to be fine, including my old HP 5MP printer. Also updated my 2007 Core2 Duo MacBook Pro without issue.

With the new version of Safari beta, I can now save web pages, whereas I had received error messages with some sites in the prior version of the beta.

item.91992

Carl Maniscalco

No problems installing the OS X 10.5.7 Combo Updater on my first generation MacBook. No noticeable difference in operation either.

item.91993

Chadwick Cipiti

Combo update flawless on an original Intel Mini, original Mac Pro, and new 15" MacBook Pro. Lots of apps on all of them, no conflicts, just 2-3 "reboots" in the process after it's done, then all good.

item.91994

MacInTouch Reader

Updated to 10.5.7 on a 2.16GHz Core Duo MBP using software update. Also updated Safari beta. No problem with update of 10.5.7 but did note that when Safari crashed, the relaunch message is the old one from Tiger giving you the option to relaunch with default settings.

item.91995

Ken Tuley

No problems with the software update version of 10.5.7 on my MacBook Pro...

Seemed like a slow shutdown and restart... but all is well...

item.91996

Jeffrey Tveraas

I updated my Core2 Duo Macbook to OS 10.5.7 via Software Update last night. After a longer than usual first boot-up all operations are nominal. I updated Safari 4 Beta afterwards as well, seems to be fine. No issues.

item.91967

J Man

The EFI-X PC as well as the Psystar computer can update very nicely with the OS 10.5.7 ComboUpdater.

Just thought some people would like to know it's a safe update.

item.91983

Jerry Godsey

I went ahead and installed the update (10.5.7) from my previous System (10.5.6) and all seems well (using Software Update). I have Address Book in an Apple Utilities folder and because of that, it didn't get updated (not sure what to do now, but it's not used often). Installed Safari 4 Beta 2 update/upgrade after and it all seems to be fine. I haven't went through a lot of Applications since the update, but the 20-25 I've used as of the last few hours, it all seems well.

iMac 2.4G (2008 aluminum), 4G RAM if that matters. Of course, like the last 10 plus years of always checking MacInTouch in the morning (and evening), I'll check back to see what others experience.

item.91964

Don Chen

I'm getting an error message that says:

The update "Mac OS X Update" can't be saved.

The digital signature for this package is incorrect. The package may have been tampered with or corrupted since being signed by "Apple".

So I am unable to update to OS X 10.5.7, despite three attempts.

Anyone else getting this error?

item.91997

MacInTouch Reader

I had previously run sudo nvram boot-args="-v" on a Mac Pro, so I could monitor the boot process in detail. After installing the 10.5.7 update via Software Update, the computer was in a perpetual reboot cycle that seemed to implicate SoftRAID drivers. In any case, after several reboot cycles, I powered off the computer (holding the power key for 4 seconds) and cold started, and then the OS came up fully.

item.91998

Erik Rieselbach

I had the same litany of problems that many people are reporting. (MacBook Pro, 1st gen. 17in.)

I was unable to download from Software Update because of digital signature problems, and after downloading the enormous combo updater I got stuck on the blue screen, which would dim and the wheel would spin, and then it would brighten up, and then dim again ad infinitum.

After a hard reboot and another automatic reboot, it reached the login screen, where the background loaded, but the login panel didn't come up. instead the background dimmed and the wheel spun, and yet another double restart ensued.

After this protracted process I eventually reached the desktop, which was very slow to load (I have several slowish login items, but it took at least twice as long as usual to get running), and the Finder kicked up the spinning beachball whenever I tried to do anything. Permissions repair gave a huge long list of things, many of them unusual for me: missing ACLs and the like. I had the general feeling that the machine is more sluggish, but after this long process it was too late to really put it through its paces.

I'm going to hold off on installing 10.5.7 on my work machine. This is by far the worst upgrade installation I've seen from Apple.

item.91999

Marlon Hollis

Last night (May 12) I tried to update using Software Update on both an Intel iMac (aluminum) and a Macbook, but got an error on both machines stating, "The digital signature for this package is incorrect. The package may have been tampered with or corrupted since being signed by Apple." I then downloaded the delta update from Apple's download page on both machines.

The Macbook went into a loop of blue screen then a screen with some crazy lines. I hit the power button and then powered back up. The Macbook went to the gray Apple screen and rebooted twice before finally bringing up the desktop. The version number read 10.5.7. Afterwards, I had to run Software Update to get the Safari 4 Public Beta update.

The Intel iMac (aluminum) also went into a loop, but with a blue screen-gray Apple screen. I hit the power button and rebooted. The iMac did the same gray screen and double reboot as the Macbook, then brought up the desktop. Version number 10.5.7. Did the Safari 4 update.

This morning (May 13) I decided to try using Software update on another Intel iMac (white), and this time it worked. So Apple must have fixed whatever was the problem with Software Update yesterday.

Note: If you are running Safari 4 remember to run Software update after the 10.5.7 update to get the Safari 4 update.

item.92000

Michelle Steiner

I wrote Garmin about the plugin not working with Safari 4, and they said that it won't work with beta software; they'll upgrade the plug in after Safari 4 becomes final.

I tested it with the beta FireFox, and it won't work with it either.

item.92002

Michelle Steiner

After successfully updating to 10.5.7 (delta upgrade from 10.5.6 via Software Update), I find that the Fast User Switching icon is missing from the menu bar.

The settings in the Users preference pane say that it should be there. Changing the view, and toggling fast user switching off and on had no effect.

item.92003

Marian Petrides, M.D.

10.5.7 update went fine.

I forgot to go the permissions repair followed by Combo Updater update to 10.5.7 route and simply did a Software Update update. Oddly enough in light of other folks' tales of woe, things appear to have gone fine. I am nonetheless doing a permissions repair now to fix any stray anomalies that I may not yet have noticed. As always, YMMV.

MacBook Air (original age and vintage)

item.92004

Carlos Phoenix

Installed in G5 iMac and once it reboots and opens the operating system it crashes the Dock app and systemui app, rendering computer useless. Attempting to install combo version but cuts off keyboard capabilities even if I access via network, so I can't enter my password to permit install again. I have rebooted 15 times and it still cuts off keyboard and Finder capabilities before I can attempt to reinstall.

item.92005

Bob Rodenburg

Did the 10.5.7 update per Software Upgrade on a dual 2 GHZ G5 last night. The computer spent an unusually long time (ten minutes or more) in the "reboot" process with a dark screen, but I could hear the hard drive making non-cyclic noises (cyclic noises are always a bad sign!) so I remained patient. There followed at least two instances of the display lighting up with the grey Apple icon and spinning icon then going dark again. However, the process completed and everything now seems in order.

Apple should add a screen-displayed warning note to users that the reboot process may take longer than usual in such upgrades. Since the upgrade was relatively small, about 250 MB, I didn't expect such a long install process.

item.92006

Rob Macaulay

Brand new MacBook Pro 17" (anti-glare) alerted me yesterday through Software Update that an update (10.5.7) was available. I took a chance and allowed the update. After the obligatory reboot I checked Software Update and it indicated the update was still available. I checked 'about this Mac' and it indicated the current software was 10.5.6. I repeated the update process (call me crazy) and after the obligatory reboot everything seems fine, and the system is now 10.5.7.

item.92007

Jai Ignacio

Updated earlier today by downloading the Combo package from the Apple site. The download was pretty snappy I must say (and I'm based in Hong Kong).

Installed on my Early 2008 MacBook and no real problems except for a slightly longer boot time (the time wheel was on screen for maybe a minute longer than normal).

Performance is pretty stable, no usablity issues encountered so far (knock on wood!).

Pleased to note some of the minor changes in the System Preferences panels, as well as the return of the quick Energy Saver power state selection via the icon in the top-menu. Icon has also been changed to match that found on the Unibody units.

Noticed some new functionality in Disk Utility, disk images in the Downloads folder are automatically recognised and listed in the left-hand side.

All in all a painless experience.

Will be pushing the update to my work's iMac suite via Remote Desktop tomorrow.

item.92008

Derek Fong

Upgraded my 15" MacBook Pro to Mac OS X 10.5.7 and the latest Safari 4 beta. No issues to report here so far.

item.92011

Bruce De Benedictis

I had trouble with Software Update until the evening, so I think the problems were related to bandwidth issues. Once I got the update properly downloaded, everything when smoothly.

I think my MacBook Pro is working better with the update, and with the new build of Safari 4. Web page loading seems a bit snappier, and I have not noticed any display glitches like those that I had been having. One website that had not been working properly with Safari 4 (something which is still noted on the site) now seems to be working.

A welcome change is that Safari pages do not change size accidentally with accidental trackpad gestures as readily as they did before.

item.92013

Ed Sikorski

I was migrating a Powerbook 15" to a MBP 15" when the update showed yesterday. I should have waited. The MBP rebooted over and over and over after [power on system test] (blue screen/spinning gear, restart...). Like another reader, I hard powered down, then restarted and it booted normally, then finished other downloads. After than, only other error was that a Symantec product was outdated and needed removal/replacement.

I decided to download the Combo to a USB drive and re-apply it, along with this to a new 24" iMac. After the initial firmware update (1.4), the update to 10.5.7 went smoother than the Macbook Pro (I believe related to the migration and previous software).

item.92014

Steve Birchall

Like many other, I got the message about not being able to save the update because it mighty have been tampered with since Apple signed it. I'll wait for further info from Apple before trying again.

item.92016

Rich Cruse

I had the same "endless loop" after installing on 2.8ghz MacPro 8 Core using the Combo Updater. Had to force shutdown and restart. Had a two or three restart sequence, then finally a normal boot.

Updated my Dad's PowerBook 1.67GHz with the 10.5.7 Delta update. No problems. Did a restart and it booted fine.

I "should" have downloaded the smaller Delta update for my Mac Pro. That may be the cause of the problem. The smaller Delta Update is designed to update from 10.5.6 to 10.5.7 while the Combo will update any Mac running version of 10.5.

item.92017

Random Person

Having the same "freeze on second sleep" issue as Peter Hull and Fred Remley. Anybody with a fix yet?

item.92020

Googe Endieveri

iMac late 2008 running 10.5.6: repaired permissions, downloaded the combo update, installed no problems, two reboots and everything seems fine so far.

Great news is you can now search (Spotlight) again when mounting non-Leopard volumes/servers over AFP!

item.92021

MacInTouch Reader

Smooth sailing this time around on both my 3.06GHz 24" iMac (nVidia 8800 version) as well as my 1st gen 2.0GHz 13" MacBook. Both running 10.5.6 beforehand without issues.

Applied the Combo to the iMac, let the Macbook download the incremental update.

The Macbook appeared to hang a couple times during the installation, but managed to pull itself out without any intervention on my part. Took maybe 20-25 min overall.

As others have mentioned, the Safari 4 update needs to be checked for separately through Software Update afterwards.

Performance seems about the same on both machines, with one exception that I'm not sure is related to new drivers in this update, or the extended maintenance on the WoW servers yesterday, but the iMac seemed to "hiccup" significantly less in Dalaran last night, even during peak hours.

item.92032

Sterett Prevost

Have updated 4 Macs so far:
PwrMac G5/2x2.0; MBk/2.4; MBP/2.16; MacP ro/8core. No issues with any of them using this process: repair permissions, update the bootable backup clone; install the combo updater; repair permissions.

item.92033

Riley Werts

Went straight to the downloaded Combo update to move my MDD dual 1.25 G4 from 10.5.6. to 10.5.7. After updating my backup (with permissions repair), did a clean restart and then launched the Updater. This finished cleanly in about 10 minutes, with an "Install Succeeded" but NO Restart button, just an "OK" to close the installer to the live desktop. Not being self-destructively curious, I then did a manual restart.

After booting up as far as the desktop image, it then rebooted and came up normally; manual restart to fully booted was just under 5 minutes. Rebooted a second time after installing the Safari 4 Beta updater which was sitting ready. This reboot was 2:45 and now running without issue. Software Update shows nothing available; another permissions repair took awhile (~5 min.), but did little.

item.92035

William Alworth

Backed up my personal info and apps on my G4 Mac mini 1.42 and proceeded to wipe and re-install Leopard (10.5.0 disc) and apply the updates. I usually do a wipe and reinstall for these type of updates. No problems at all. Did take a long time to install the 10.5.7 combo update, but other than that, it went fine.

item.92036

Ed C

I downloaded the "Delta" (10.5.6 --> 10.5.7) update from Apple's downloads page for my 1.67 Ghz PowerBook G4.

After the update was installed, I pressed the restart button and, like others have reported here, the screen cycled between a couple blue screens and a garbled video screen (diagonal lines and noise). Pressing and holding the power button forced my PowerBook to shut down.

Restarted, and afterwards I used software update to upgrade to Safari Beta 2. FWIW, since I read MacInTouch first, I was prepared and didn't panic when I saw the messed up video.

item.92037

MacInTouch Reader

Non-eventful - as it should be

item.92039

Pierre Maldonado

I installed the update through the software update with no problems. Now my Macbook Pro is horribly slow, with constant hang-ups and freezes. I click on anything, an application, an item in finder, a command inside of an application. Everything is terribly slow. Used MacTuneUp and ran maintenance, and optimization commands with no effect. It boots up o.k. and initially, the performance seems fine. within less than i minute of starting to use the computer, it begins to work extremely slow. Any ideas? or similar experiences? help!

item.92041

MacInTouch Reader

No issues whatsoever.

item.92042

Michael Bayme

Uneventful update on intel Mac Mini and Unibody MacBook via software update. No unusual extensions other than Nokia multimedia and isync plugins.

item.92043

Riley Werts

For Peter Hull and Fred Remley, who are having trouble with their MacBooks freezing on the second sleep after a fresh start:

Macjosch over on MacFixit had the exact same problem and found a solution that worked for him:

"Removed Application Enhancer (in System Preferences, 3rd party) and Sleep Mode works again. Switch Res installed it some time ago."

Application Enhancer seems to be a common culprit in update problems if it itself is not kept up to date. If either Peter or Fred do have this System modifier installed, they could try removing it, or at least making sure it, as well as the application that relies on it, is up to date. They may not even realize that some utility they installed uses this haxie. See Unsanity.com for more about it.

item.92047

Mark Clark

17" PB G4 - No problems installing from "Software Update" just a little patience (15 min.?) after the install thermometer says installation complete, with generic screen and cursor while hard drive spins, then restart twice and voila, new system.

item.92048

Vladimir Vooss

David Green wrote...

"Just installed the 10.5.7 upgrade on a Mac Mini (my "staging" upgrade machine)..."

Same thing happened to my MBP '07, sort of.... except the loop spun once and froze. I shut the machine down. Then I started the computer and it looked fine - but no double restarts, AhHa, sez me - I restart the MBP and it goes through its double restart and again things look fine. A friend calls on the phone, I put the MBP to sleep, and all through the phone conversation, the MBP, with lid closed wakes and goes back to sleep and wakes, continuously. I zapped the PRAM and reset the"#*#*&#&" controller by shutting down, pulling the AC, removing the battery and holding the start-button for 5 seconds. It's been fine since. I've tried most of what I do on it, even file sharing across to the other computer.. Glitchy experience, but fine, I think, I hope...

item.92049

David Johnson

I downloaded the incremental update and used it to update a 2008 Mac Pro, 2009 Macbook Pro (17), a 2009 24 inch iMac and a 1.66 G4 TiBook with no problems on either.

I had Safari beta 4 on the 17 MacBook and the Mac Pro. Didn't see any problems before I updated Safari. I did that last.

item.92050

Ed C

I hadn't seen anyone else report this so I thought I'd share it.

A known issue with MS Word 2008's toolbox and MacOS X spaces appears to be corrected (for me, anyway).

Prior to 10.5.7, if you were running Word 2008 and you changed spaces and changed back, Word's toolbox window would be corrupted. MS claimed this was because they were using grouped windows, which apparently didn't play well with spaces. (Also, Word's cursor might disappear.)

Now in 10.5.7, moving to another space and back no longer corrupts Word's toolbox window (and the cursor no longer disappears).

Note that if you manually move Word to another space, the Toolbox remains behind, even if you open and close the Toolbox window. The fix is simple--just move the Toolbox window to the same space as Word is in.

This also appears to be fixed for Excel 2008.

item.92051

Zo Spencer

No problems upgrading here, once I went to the source (apple.com) and downloaded the combo from there. I'm thinking Software Update is a funky way to go, and this time, for the first time, it refused, anyway. Something wasn't signed right. No such problems with the downloaded combo.

My MBPro late '08 had some startup issues -- you know the way updates restart several times, lately. So I helped it along with a Safe Boot and a Restart, and all was resolved. BTW, this is all done upon a clean machine with no apps running, permissions repaired, disk repaired (as needed.)

Afterwards, an update Locate database helps speed things along. Everything's smooth and perhaps slightly faster.

item.92053

Carlos Jorge

Date and Time have disappeared from the menu bar after installing Leopard Update 10.5.7 on an 2.66 GHz Intel Core 2 Duo Macbook Pro

Selecting "Show date and time in the menu bar" on system preferences will not work. Re-opening System Preferences again the box appears unchecked.

item.92054

Randy Cooper

I updated my two Intel Core 2 Duo Mac Minis and dual processor PowerMac G5 this afternoon, after backing up each one using SuperDuper. I used the 10.5.7 combo updater to upgrade from 10.5.6. The upgrades went quickly and with no problems. So far all the applications I have tried have worked.

Enjoy!

item.92056

MacInTouch Reader

Euphonix support just send me this mail:

Dear Artist Series owner,

Please note that the new Mac OS update released yesterday, Version 10.5.7, breaks support for the feature in EuControl that automatically detects what control surfaces are attached to your network.
Euphonix is working on a fix " please DO NOT update your Mac OS until we release a software update that addresses the issue, as your MC Mix/MC Control will not be seen by your Mac.

For those users who have already updated to Version 10.5.7, you can roll back your Mac OS to the previous version if you are using Time Machine.

Regards,

Euphonix Support

Best regards

item.92058

MacInTouch Reader

Ran the combo on my Intel mini (1.83 C2D) and have had no issues whatsoever. Rebooted twice after the update then started up normally.

Does seem a bit snappier and seems to be using a little less processor, but time will tell.

I haven't updated my Macbook (same specs as mini) yet, but I will later today.

May. 14, 2009

item.92061

Joe Gurman

I applied the 10.5.7 update to a number of machine at work and home yesterday evening, with varied results:
(1) 2008 8-core Mac Pro, no issue with download, but after installation and reboot, went into very long (~ 10 minute) fsck (pale blue screen, spinning spokes) before rebooting successfully;
(2) original (2006, single-core, 2 core) Mac Pro - no issues;
(3) current-generation MacBook - no issues;
(4) four remote machines via ssh login and Terminal command line softwareupdate --install: (a) early model PowerPC G5 (single processor), (b) 1.9 GHz Power Mac G5 (late 2005, iSight), (c) and (d) 2 x dual-core 2.5 GHz PowerMac G5's: (d) download and installation OK on all, *but* command line refused to recognize admin user password for sudo shutdown -r now to reboot at end of installation (first time this has failed), manual reboot successful on all, but nfs mounts were hosed on (a), despite directory Utility settings looking OK; and finally,
(5) another 8-core, 2008 Mac Pro: Got the already reported "can't be saved" error twice on very slow downloads (lots of traffic?), so I went to the http://support.apple.com/downloads/Mac_OS_X_10_5_7_Update page and simply downloaded the updater via http. Installation succeeded up to the pale blue screen fsck's with the spinning spokes. The machine went into a cycle of about 3 rotations of the graphic, followed by the screen background getting a little brighter and going blank. After this cycle repeated 6 or 8 times, I power cycled via the power button, and the system rebooted without issue.

The post-remote softwareupdate issue of the command line not recognizing an admin user's password for sudo is troubling: will we have to sit in front of every machine to update it? Will Apple Remote Desktop stay connected through a reboot (not)?

item.92062

W. Keith McManus

Download and installation of update 10.5.7 was completed without any problems.

iMac Intel, iBook Intel (white)

item.92063

Greg Chesney

No problems with (combo) update - except that after 2 reboots hung at white screen (I have SoftRAID). A hard power-down and reboot resulted in a RAID rebuild, but everything seems fine now.

I've had the hang before when doing updates. I don't know if it's SoftRAID or not.

item.92064

Luis Sequeira

After backing up and repairing permissions, ran the combo update without any problems.

I was disappointed to see that an infamous bug in Preview (or is it Preview vs Spaces) is still not resolved: if Preview is set to a specific space (say, space 5), and you double click on a jpeg, png, or gif file in another spcace (say, 1), the file opens in the correct space (5), but you are left in space 1 and have to manually switch to space 5. Apple has known about this bug for ages, but still no solution. Intriguingly, pdf files are not affected by this issue (in the above scenario, you *would* be taken to space 5, correctly, if you open a pdf - although the order of the windows in Preview is mangled).

Why Apple's omnipresent and tremendously useful and versatile Preview application behaves so poorly with such a useful feature of Leopard as Spaces, even after 7 updates... is beyond me.

item.92065

Dan Boehlke

I installed the 10.5.7 update after a full backup on my MacBook Pro 2GHz Core Duo. I was nervous after reading the feedback of others, but all went well.

item.92066

Stephen Hart

No issues on two Macs with 10.5.7, using Software Update to do an incremental update.

G5 2x2 (2003) and PowerBook G4 (2003)

There were a few permissions to repair after the update.

item.92068

Tim Fields

Today I installed the 10.5.7 update on 5 different Macs: 4 iMacs and one MacBook (all Intel, all were running 10.5.6 prior). I repaired permissions on each before updating, and I used the combo updater for each.

On one iMac, the screen froze when I clicked the Restart button after installing. After holding the power button for a few seconds, it rebooted and has been running without any difficulties. The installs on the other 4 Macs were without incident, and all appear to be running just fine.

item.92071

Zac Matthews

I had the same install as others. After a hard restart and a triple self-restart my machine (Powerbook G4) worked well.

*But*... when I tried to use my scanner, Microtek Scanwizard 5 would not open due to missing files. When I ran the Scanwizard installer it froze while updating Receipts.

My computer will not restart. Not even in Safe mode. Files (like /Library/Receipts/BaseSystem.pkg) are missing.

Be very wary of ScanWizard with 10.5.7 - it was a dubious program to start with!

I'm still working on a solution - I'll try to start by reapplying the update. Otherwise I might have to do an OS 10.5.0 install and apply all of the updates again.

item.92076

Jay Craig

I just updated my June 2008 17" MacBook Pro with 2 Gig of memory and a Hitachi 200 GB 7200 rpm drive (Combo Updater Version 3.0.2 (281)) with no problems, just the double reboot, and up and running. OS X 10.5.7 reports Build 9j61. The usual precautions were observed (SD backup and repaired permissions).

item.92078

Don Fraser

Combo update worked fine on both my early 2008 15" MacBook Pro, and my white 13" Macbook, both Intel and bought last year.

But I ran Yasu first, which may have made a difference.

item.92081

Ralph Finley

Hopefully I'm in the 90% that didn't have any problems, downloaded in less than an hour, installed in a few minutes, can't tell the difference yet, will check out changes tonight at my leisure. So far: Excel, Word, FirstClass, ARD, Safari 4, Firefox, Omnifocus, Omnioutliner, Phoneview and Rosettastone work fine.

item.92086

Tom Neale

I've already updated a couple of standalone machines to 10.5.7 and everything is fine, expect for printing.

But, at the school where I manage dozens of machine using WorkGroup Manager, I updated one 10.5.6 client machine (G5 PowerMac). Big problem. Any login attempt, whether to a local admin account or to a network account gives me a message box asking me to:

"Enter an administrator's user name and password to allow ManagedClient to make changes."

Great, except that I cannot click in the username or password boxes to type anything at all. The Details disclosure triangle doesn't work. The Cancel and OK buttons are likewise un-clickable. All I can do is move the mouse around.

I tried rebooting into Safe Mode - same result. I can't login.

I do not know if this was a problem unique to this machine because it is the only managed machine I've updated so far - this behavior stopped my dead in my tracks. But it is now working again. I figured if the managed client part was broken, maybe I should stop managing the machine to fix it. That seems to work.

Here are the steps I used:

1. In WorkGroup Manager, removed the machine from the managed group of computers. Save the updated list.

2. Restart the affected client machine.

3. Login to the client on a local administrative account (it works now!)

4. Trash these files and folders:

/Library/Managed Preferences
~/Library/Preferences/com.apple.mcx.manifests/
~/Library/Preferences/com.apple.MCX.plist

5. Logout

6. Add the machine back into the Managed Computers list

7. Reboot the client machine

I hope I do not have to do this for every 10.5 machine I have. I suppose I should have tried simply removing it from the managed computer list, restarting and re-managing it without deleting the files. Maybe next time.

item.92091

Wil Van Cleve

For my part, since installation, my Macbook has been going to sleep randomly and the fan has been running full blast for no apparent reason. I haven't determined a cause yet (is the fan confused, or is the computer actually running hotter), but it's concerning behavior....

item.92092

Andrew R

10.5.7 update on an iMac G5 2nd gen. Downloaded the Combo update from Apple. Unmounted and Disconnected my FireWire drives. Ran Cocktail. Ran DiskWarrior. Applied the update. It took quite some time to restart the first time but it did eventually, Second restart was quicker. Ran Software update and grabbed the new Safari Beta Update. Ran Cocktail again (full pilot with restart). All is well. Have not noticed anything much different.

item.92093

Michelle Steiner

I got the Fast Switching icon back on the menu bar by shutting the computer down and turning it back on.

Before that, not even double-clicking User.menu in /System/Library/CoreServices/Menu Extras/ helped.

item.92094

MacInTouch Reader

No problem installing the combo updater on iMac aluminum 20", iMac Plastic 17", and unibody MacBook. I will wait a couple days then go for the OctoMac Pro.

item.92096

Vox Locus

Downloaded all (gag!) of the nearly 800 meg combo update since I have several computers.

Installed it on one (to test), 1st gen 1.83 iMac 17"

No problems. Can't tell any difference in system. What was in there?

item.92100

Art Hicks

I installed from Software Update into a late model 17" MacBook Pro and had no problems whatsoever. Within 20 minutes or so I was back to hassling with trying to configure TWiki using Unix commands. Too bad Apple doesn't also provide Wiki software. As far as I can remember, I've never had any real problems updating my Macs over the years, now 2 decades.

item.92101

Peter E. Barck

My upgrade from 10.5.6 to 10.5.7 went flawlessly in less than 10 minutes. Machine works well, not one problem.

I have a MacBook Pro 17", 2.6GHz, 2GB RAM. Before upgrading I ran Cocktail and Permissions Repair. I booted into SafeBoot and used the Combo10.5.7 upgrade I previously downloaded. This is a procedure I always use and never experienced any OS X upgrade problems.

item.92102

Joe Houghtaling

Downloaded the Combo Updater. (Thanks for the link!) After reading the comments here, I figured I stood a good chance. So I updated permissions and fired away.

The update's been running for a few hours now with no apparent ill effects.

item.92105

William Rainey

Ran the Combo updater without event, but today find the novel problem that both of our Airport Extremes (one n version, one g) cannot be accessed [by] Airport utility 5.4.1 (though they are hard wired) via the MBP that has 10.5.7 whereas a Macbook (with an earlier utility version) has no trouble altering configurations. There is as always the problem of multiple sufficient causes.

item.92112

Scott Little

I downloaded and ran the Delta update on my black MacBook - from 10.5.6 - after performing all the usual maintenance chores. The update has been stable to this point, with only one very minor issue. I use the Notes feature in Mail - often flagging notes for emphasis. The first MobileMe sync after the update caused all the flags to disappear.

The update has not solved the random and sporadic loss of bluetooth connection to my Wireless Keyboard and Mighty Mouse. That can be very frustrating at times.

item.92113

Chuck Weinstock

I used software update on my new 17" MBP and it appeared to go flawlessly. (I had a full backup and had fixed permissions, etc.)

The only strange thing I've noticed so far is that Mail lost some of my rules. I was able to retrieve them from the backup but I'm wondering what else might have changed behind my back?

item.92114

Erik Rieselbach

I posted earlier about the difficulties I had installing this upgrade on my MacBook Pro. After satisfying myself that the machine was running normally despite the messy installation process, I decided to take the plunge and install the upgrade on my work machine (Mac Mini). I had a SuperDuper clone in hand in case of catastrophe.

What a difference! I was able to download via Software Update this time. After writing and installing files and a double restart, I was back at the desktop and running without a problem and with none of the sluggishness that my other machine had initially displayed. The installation went very quickly, too.

item.92115

Robert Mohns

10.5.7 Combo Update applied to iMac Core 2 Duo (2.0 GHz, 20", 3 GB RAM), update went fine.

I then let Software Update install the Safari 4 Beta security update. After Software Update finished doing its thing, it prompted for a restart. Upon approval, all apps quit (per usual shutdown procedure), then the machine appeared to stop doing anything (except moving the mouse) except show the desktop picture.

I left it alone for 10 minutes, then forced the iMac to turn off. Tunred it back on and everything is running fine.

Puzzling, annoying, but apparently harmless.

item.92116

Brad Hurte

Scott Little said:

The update has not solved the random and sporadic loss of bluetooth connection to my Wireless Keyboard and Mighty Mouse. That can be very frustrating at times.

I've had similar problems that were resolved by changing the batteries. Older batteries I was using showed a full charge in the System Preferences pane, but apparently weren't generating enough juice to maintain the connection. Newer batteries resolved it for me.

item.92117

MacInTouch Reader

Installed the update last night on a x-mas 2007-purchased MacBook with no problems at all so far...

item.92118

Bob Beatty

The update has gone fine in all respects EXCEPT both of my printers have decided the black ink cartridge isn't compatible or is empty...

HP Deskjet 5740 (not compatible)

Epson Stylus 880i (empty)

Strange, I'll try replacing them

item.92119

David Flood

Downloaded and updated 10.5.7 on both my Santa Rosa MBP and 2006 Mac Pro through Software Update.

The MBP updated fine, but the Mac Pro (w/NVIDIA 7300 graphics) no longer allows me to select the 1920x1200 native resolution of my L246WP 24" screen (attached via HDMI). Instead, I only get the option of 1920x1080 or 1600x1200. Grr.

p.s. is anyone successfully running an ATi Radeon 4870 on the Mac Pro (2006) after this update? I know that various people on the Internet had claimed that they were able to use beta drivers to do so.

item.92069

MacInTouch Reader

After applying 10.5.7 Combo Updater I have the same problem as Peter Hull i.e. on Macbook Pro sleep only works once - on a subsequent try to put it to sleep the computer locks up and has to be powered down in order to restart.

item.92079

Brian Shaw

Upgrading to 10.5.7 hoses up the latest build (3844) of Parallels Desktop 4.0. Lots of discussion on the Parallels forums and the fix is here:

http://forum.parallels.com/showthread.php?t=90280&page=2

Specifically:

1. run the "mkdir ~/Desktop/pddrivers_backup" command.
2. run the "sudo mv /System/Library/Extensions/prl_* ~/Desktop/pddrivers_backup" command.
3. run the "ls /System/Library/Extensions | grep prl" and write down its output.
4. run the "sudo touch /System/Library/Extensions" command.
5. Reboot.
6. Run the "ls /System/Library/Extensions | grep prl". Check if its output is empty - it should be empty.
7. If so, check if the issue is still there.

item.92106

Ron Roszkiewicz

I upgraded to 10.5.7 and immediately after doing so launched Acrobat and it crashed and would not start-up. I downloaded the 9.1.1 patch and installed it. No difference. Since Adobe provides an Uninstaller I used it to remove all traces and reinstalled from disk. After doing so it ran just fine. I tried to install 9.1.1 to the newly installed 9.0.1 and the Patch application would not recognize it as worthy of an upgrade. All seems to be working well now. Was it all a coincidence? I don't think so.

item.92111

Nate Goldshlag

There is a thread on the sleep freezing issue I posted about yesterday at   http://discussions.apple.com/thread.jspa?threadID=2005687
Some others are having the same issue, while others are not.

item.92120

Pierre Maldonado

I posted earlier about having horribly slow performance and hang-ups after update. I ran disk utility and repaired my disk permissions, and all is well. Runs quite a bit faster than before the update as well.

item.92121

Steve Swonk

Installed 10.5.7 from combo updater on MacBook3,1 (late 2007) 2.2GHz/2GB/120GB stock with no issues. Installed without any special procedure (NO fsck, repair permissions etc.) using admin account with FW drives unmounted and unplugged. System rebooted, finished itself and rebooted again, straight into standard account and working fine.

item.92122

Robert MacLeay

No problems or "unusual behavior" using the combo on my mid-2007/Santa Rosa MBP or early-2009 iMac.

Specifically, no sleep problems on the MBP.

On both, however, fixing permissions after the update revealed more than a dozen items needing correction, most noticeably Front Row and good ol' iTunes.

What is it about iTunes? It seems as though every update to this program messes up its permissions.

Next Page...


MacInTouch Amazon link...

Talk to MacInTouch     Support  •  Find/Go